Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Curt - NC

Pages: 1 [2] 3 4 ... 79
16
The Hawg Forum / I Think It Followed Me
« on: January 20, 2022, 10:35:32 AM »
It seems like the cold weather must have followed me to NC  (giggle)

Not really. It's been great here overall, with many days in the los, and even some in the 70s. But we're supposed to have some freezing rain and ice over the next couple of days, and then a streak of weather in the 40s each day.

Based on the weather patterns, though, that will likely be the worst we will see of the winter here.

I've been checking on the weather back in RI from time to time, and it makes me glad I left when I did.  :nod:

Stay warm everyone!

17
The Hawg Forum / A New Chapter, but Not in the Northeast
« on: December 28, 2021, 10:39:37 AM »
Well, after working our butts off for the last 6-8 weeks, my wife and I left RI on 12-16 to make the 750 mile drive to NC, where we bought and moved into a new home.

We are no longer living in the northeast, but I will continue to run this site and make posts as I learn new waters here in NC.

We are just about settled into the new house, so I hope to get out on the water sometime in the next couple of weeks.

The weather here is drastically different than RI. We had mid 70s on Christmas day, and today is supposed to be in the low 70s. I think I can like this   (giggle) :nod:

I hope everyone is staying warm!

18
Ice Conditions / Ice Conditions 2021-2022
« on: November 28, 2021, 01:02:38 PM »
I drove through an area today with a marsh and saw skim ice on most of it.

It has begun  :facepalm:  :crying:

19
The Hawg Forum / Happy Thanksgiving!
« on: November 25, 2021, 08:25:47 AM »
Happy Thanksgiving, everyone. I hope you have a great day  ;D

20
The Hawg Forum / Been Doing a Lot of Scouting
« on: November 23, 2021, 03:04:25 AM »
I've been spending a fair amount of time recently scouting out the new area I will be living in in NC.

There looks to be a fair amount of good bass water there in a handful of lakes, but also some tidal rivers that hold good bass as well.

Looks like I've got some serious exploring to do once we get there!   :nod:

21
The Hawg Forum / Where it's Warmer
« on: November 07, 2021, 07:53:14 AM »
Well gang, my wife and I have bought a new house in NC and we're moving south!

No more snow for us, starting in late December.

I've lived in New England all my life, but it's time for a new chapter in a land where it's warmer and where the bass growing season is basically year round  :D

Our new house is being built and should be ready for us to move in just before Christmas.

The community where the house is located is a former golf course, so there are small ponds scattered throughout the neighborhood, and I have been told that the ponds have bass in them. I was there back in October and saw a school of tens of thousands of small baitfish moving around in one of those ponds, so that was a good sign  :yes:

There are also lots of water bodies within an hour or less with good bass fishing, so I should be all set when it comes to that  (giggle)

We don't have a definite moving date yet, since our house here in still on the market, but we don't expect it to take long for it to sell.

More to come as things progress!

22
The Hawg Forum / Took the Win This Weekend!
« on: June 07, 2021, 09:40:51 AM »
I fished in a club tourney this past weekend.

The first half hour was dead, but I made a change to my presentation and it worked for me for the rest of the day!

I bagged 17 1/4 lbs., including these nice bass!

The biggest was a tad over 5 1/2. The smaller of the two was 4 3/4 lbs.

It was a great day on the water   :yes:




23
Northeast U.S. Fishing Reports / First Night Fishing Trip of 2021
« on: May 24, 2021, 09:57:28 AM »
Got out Friday night for a few hours.

The skies were mostly cloudy, with a steady breeze of 5-7 MPH the entire evening.

Water temp was just over 72.

The bite was intermittent, but I landed 5 bass in roughly 4 hours, with this one being the best, at a tad under 6 lbs.

Got it on one of my own spinnerbaits.

The next biggest was 2 3/4 lbs., also caught on a spinnerbait after dark.





24
The Hawg Forum / Poll Regarding Your Personal Best Bass
« on: May 19, 2021, 10:58:32 AM »
Let's have some fun and talk about what bait landed our personal best bass!

After you vote, post below and tell how you caught it on that bait  :)

25
Boating Forum / My Big Floating Tackle Box
« on: May 06, 2021, 11:40:25 AM »
Every year I buy or make new lures and baits. Most of these get put in my boat.

Many of them get stored in the boat "just in case I need them". Those types of baits end up in plastic boxes or zip loc bags so I will have them if I happen to need them at any point.

Sadly, many of those baits never see the light of day again. They get buried and forgotten.  :facepalm:

So, this week I decided to pull those items from the great abyss ( (giggle) ) and sort through them all so I could organize them and make them easy to find if I want to use them.

Here's what I found when I dug them all out!













I will be putting some of these back in my boat, but many of them will be hung on pegboard in my garage, where I can easily see what I have and grab it when I'm preparing for a trip or tournament.

It's crazy how much stuff gets collected and then hidden away in the dark corners and recesses of a bass boat!  :o

26
Boating Forum / Minn Kota Talon Stomp Switches
« on: April 24, 2021, 09:00:48 PM »
I recently installed a second Minn Kota Talon to my boat, giving me a pair of them now   :yes:

I have them paired with each other via Bluetooth, as well as pairing them with two hand-held remotes.

I had been using the standard wireless remotes to operate them. One is mounted at the console. The other is/was mounted on the bow, in the recessed trolling motor tray.

I was getting tired of having to bend over to operate the bow remote, especially if I had to use it while fighting a fish.

So, I decided to get a foot switch.

After doing some homework, I decided to get the Bluetooth Stomp Switches for the Talon/Raptor, not the triangular multi-switch.

I ordered them and got them from West Marine earlier this week.

The next day, I got them installed and paired up, so they operate both Talons at once.

Wow! I can't wait to use them on the water.

A simple double stomp on the Down button deploys both Talons effortlessly. And a single stomp on the Up button retracts them both.

This is going to be a huge upgrade for me  ;D

p.s. If you look closely, you can see where I had mounted the standard handheld remote in the recessed trolling motor foot pedal tray.




27
Lure Making / Spinnerbait Tweaks!
« on: April 22, 2021, 11:32:01 AM »
I just uploaded my newest video to YouTube.

Tips to Give Your Spinnerbaits More Vibration - Catch Bigger Bass!
 

28
Boating Forum / Trailer Woes
« on: April 15, 2021, 04:09:36 PM »
Well, it looks like my trailer has reached the end of the road  :crying:

I spent the money to put new hubs on both axels a few weeks ago, figuring that would keep me going until I replaced the trailer in a couple years.
Nope. Didn't work out that way!  :nope:

While I was in the garage a couple days ago, I happened to stick my head under the trailer to check something, and while I was under there, I spotted some rust that looked pretty scary.

I grabbed my flashlight and checked it out more thoroughly. Here's what I saw.




















So, I did some scrambling, researched some replacement aftermarket trailers and made tons of phone calls.

No matter who I called, there were no trailers in stock anywhere for my boat. I managed to find one galvanized trailer that was available in Worcester, MA. But it was bigger than what I needed, so I passed on it.

Every dealer I spoke with said it would take up to 15 weeks (or more) to get a trailer in once it was ordered  :o

Ultimately, I finally found a trailer dealer in East Haven, CT who sells Venture trailers. It was the brand I wanted. Sadly, he only had trailers in stock that were either too big or too small for my boat.

But, on the positive side, he just happens to be the biggest Venture dealer in the USA, so he gets trailers in regularly. He said that if I was to order the model I wanted, he could have it in within 6 week... maybe less.

So, I placed an order and put a deposit down on a Venture VAB-2625 aluminum trailer.




It's not made specifically for my boat, like the current trailer was. But it will last me for whatever time I own the boat, since it won't rust. That's all I am concerned with at this point.

To top it off, it comes equipped with some nice wheels and the aluminum frame looks much better than galvanized steel does.

Now I just need it to arrive on time (or earlier) so I can put it under my boat.

In the meantime, I will nurse mine for as long as I can. And I have a friend who can loan me a trailer if I need to while I wait  :nod: :)

29
The Hawg Forum / Not Bad Overall
« on: April 02, 2021, 01:13:22 PM »
I have to admit that the weather so far this Spring hasn't been too bad overall.


Today is a tad chilly, but it's supposed to warm right back up into the 50s over the weekend  :yes:

30
Boating Forum / Fixing Unresponsive Minn Kota Talons
« on: April 01, 2021, 11:00:50 AM »
A little over a month ago I installed a second Talon on my boat.

After installing it, I successfully paired it with my first Talon, and then I also made sure that both of the remotes in my boat would operate both of the Talons, either together or individually.

No sweat, right?

Well, that's what I thought too. And then last week I decided to finally get the boat on the water for the first time so I could fish and try the Talons out for the first time as a pair.

As I walked into the garage with the remotes in my hand, I pressed the Down button on one of the remotes. Nothing happened. So I grabbed the other remote and tried it. Nothing happened. Then I walked over to the new Talon and pressed the Down button on it. That unit went down. I pressed the Up button and it retracted normally.

Then I walked to the Port side, pressed the Down button and watched as nothing happened.

What the heck?

I spent the next 20 minutes or more checking connections, fuses, etc. All was perfect.

But neither Talon worked. They were seemingly dead.

My next logical step was to call Minn Kota and speak with their tech support department. So, that's exactly what I did.

I spoke with a guy named Dave, who was super helpful.

He walked me through clearing the memory on both Talons and both remotes, and then re-initializing them.

Then, he had me install the Talon app on my phone and connect to the Talons with that. The app immediately alerted me to the fact that there was a software update available for both units.

Next, I installed the update to both Talons.

Then I paired the two Talons and verified that they both worked with the app on my phone.

Next, I paired one of the remotes with the Port side Talon.

I then tested that remote and saw that both Talons worked as expected.

I then paired the other remote with the Starboard side Talon and tested it. All was good.

A few seconds later, the lights on the first remote began blinking, which indicated that the software update that I had installed in the two Talons was now being uploaded to that remote from the paired Talon.

That update finished and than I saw the other remote start blinking, indicating that the same thing was taking place with that one.

Once the updates had completed, I tested both remotes and found that neither of them worked.

Next, I took the battery out of the first remote and reinstalled it, powering that remote back up. Then I did the same with the other remote. Nothing worked on that one either.

So, we walked through the steps of clearing the memory on both remotes and both Talons one more time.

Then we paired the Port side Talon with one remote and the Starboard side Talon with the other remote.

Once we had gone through this procedure again, everything was working normally and has stayed working since then.

Apparently the problem was the result of a combination of two things;

1. The steps that I had used to pair them once I had installed the second Talon.
2. The fact that a software update was needed.

Those two facts caused them to become completely unresponsive, acting as though they were completely dead.

So, if you have a Talon, or a pair of Talons, and they become unresponsive, check your electrical connections first, and verify that there is voltage there.

Once you've verified that, walk through the process of clearing the memory of your remotes and the memory of your Talons. And then re-pair everything.

I would strongly recommend also installing the Talon app on your phone and installing any software updates that might be available as part of this process, but do it before pairing the remotes with the Talons.

I hope this might help someone who is wrestling with unresponsive Minn Kota Talons.

And if all else fails, call Minn Kota tech support. They are super helpful.

Pages: 1 [2] 3 4 ... 79